Saber Forum

Ultra Sabers Discussion => Obsidian Technical Discussion => Topic started by: daxmaul on February 19, 2014, 05:54:32 PM

Title: lost flash on clash
Post by: daxmaul on February 19, 2014, 05:54:32 PM
Hey everyone. I just downloaded the old republic sound font onto my ultrasaber guardian. It had episode 1 on it with flash on cLASH. Now the old republic soundfont works, but I lost flash on clash. Any one know what I may have done wrong?

Title: Re: lost flash on clash
Post by: Racona Nova on February 20, 2014, 06:21:38 AM
First, look at the launcher with the saber connected if the box(es) saying "Enable Flash on Clash Light Effects" and "Enable Lockup Light Effects" are checked. If not, check them and click "Write Parameters".
If they're already checked, then check all wires, especially the one connected to the FoC pin on the soundboard. Maybe it has got loose.

PS: Don't forget to post in the Rules section!

Title: Re: lost flash on clash
Post by: sabedroid on March 12, 2014, 07:04:56 PM
I have the same problem with my brand new first purchase -- the FOC was working until I tried to tweak the duration, and now it isn't working. The clash sound plays, and when click "Test FOC" in Obsidian it works, but it just doesn't work when I actually clash the saber. Where is this pin of which you speak, and will I be able to fix this even with pretty much zero hardware skill? Thanks for any help.

Title: Re: lost flash on clash
Post by: Deep on March 12, 2014, 08:19:39 PM
Lots of times the Flash on Clash can go out if the saber has been used with the wrong version of the Launcher.  If you have multiple accounts on your computer operating system, please make sure that you are logged in as an administrator.  And please uninstall any past installations of the Obsidian Launcher or any sort or type or version whatsoever as the administrator and re-install it as administrator from here: ( (this is always the latest version of the Launcher).

Make sure the saber is turned on and then while the saber is already on plug it into your computer with a Mini USB cable.  Then run the program with the saber plugged in and when you run the program please right click it and select "Run as administrator"

Then click Restore Defaults in the bottom right hand corner and then click Write Parameters so that it writes to the soundboard and this should fix the issue with the Clash not working.

If this doesn't work or if the saber has not been used with the launcher then a wire was probably pulled loose.  Namely the flash on clash wire from the soundboard harness.

Title: Re: lost flash on clash
Post by: sabedroid on March 12, 2014, 08:36:47 PM
Hi Emory -- thanks for the quick reply. I do have the most recent Launcher and followed all of the directions... the FOC even works when I click the test button and I restored the defaults and the FOC enabled is checked and everything.

My worry is that the culprit is a loose wire, since I don't know about that stuff... is it a simple fix that someone could walk me through? Do I need any special equipment? Seems like it wouldn't be worth shipping back just to fix something possibly so minor, but at the same time I'd love to have all connections checked to make sure they won't come loose again since I do plan on using the saber for dueling. Thanks again for any help.

Title: Re: lost flash on clash
Post by: sabedroid on March 14, 2014, 05:49:40 PM
Just to update this -- Emory gave me a bunch of things to try, including re-installing the launcher (as administrator), running it (as administrator), resetting the settings in both the sound board and the Emerald driver. It still wasn't working, so I went into the color picker and set the thing to flash 20x red to blue, hit the test button (which was working), and then set it back to play once, and now it's working. Not sure why that fixed it, but in case it helps anyone else :-) Thanks again Emory and Ultrasabers.

Title: Re: lost flash on clash
Post by: Mackgiver on February 06, 2016, 09:10:53 AM
I have the same problem, my obsidian its a v2 soundoboard with the v2 launcher, i tried to factory reset, and reinstall the launcher, previosly clear last version and the toc donīt  work never, its a pitty, how can i do to enjoy again  flash on clash?

Title: Re: lost flash on clash
Post by: Mackgiver on February 07, 2016, 07:18:32 AM
i solve the problem, once time unistaled launcher v2 and erase all archives, i installed launcher v3, and restore default setting and  FOC works perfectly.

Title: Re: lost flash on clash
Post by: Gilgamesh on December 09, 2016, 09:16:48 AM
I also lost any FOC after changing sound fonts.  I bought my saber pre-2013 so needed the older version of obsidian launcher...THERE IS NO CHECKBOX to turn on FOC.  I can change the sounds but FOC is gone....sound is there but no flash...unless its a HUGE coincidence that a wire got disconnected while changing sounds....its the software.  I was told to use the latest version of launcher but I told them i had a pre-2013 saber.  The technician actually asked me if I had the emerald driver?  So I worked a while, uninstalled my launcher...reinstalled the V4 and voila....OF COURSE IT SAYS I NEED an earlier version v1 or v2 but good luck finding V1 ANYWHERE....again...V2 was working for sounds but since there's no way to activate FoC, its useless.  I did try "restore to factory defaults......still not working.  I have to say, this all started when I was looking into buying a new Kylo Ren saber but that's not going to happen now

Title: Re: lost flash on clash
Post by: Racona Nova on December 09, 2016, 11:17:06 AM
Okay, I'm not familiar with the older pre-2013 sound boards, but I just watched the v2.2.2 launcher video again so that I can try to help you.

First, have you already reset your sound board, i.e. removed the batteries for some seconds, then re-inserted them and checked if the FoC works again? Also, does the lockup flash work or is there the same problem?

Second, when you chose "Factory Defaults" in the v2.2.2 launcher, did the slider of the "Lockup Flash" also reset to a certain position and if so, what's the value? I can imagine that when it's accidently set to 0, it will in return disable the FoC and lockup effects. Also, make sure you click on the "Send" button, otherwise the settings aren't updated. I know, it's obvious, but often (and especially in such situations) the obvious isn't always the first thing you do or think about.

Third, it can indeed happen that a wire comes off or breaks during that process. Remember, every time you pull the battery pack out, you also put stress onto the wires. So check all the solder joints and points and of course the whole wire for any damage

It's really sad that you ran into this quite massive and annoying problem, and I understand if you are disappointed, but I tried my best to help you. Normally the CS from UltraSabers is very efficient and knows its stuff, so that's quite odd what you experienced.