Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: 1 ... 18 19 [20]   Go Down
Author Topic: New Obsidian Launcher Available (UPDATED 05/21/2015)  (Read 145506 times)
Abrahm Lion
Knight Aspirant
*

Force Alignment: 4
Posts: 10


In stereo, where available.


« Reply #285 on: January 11, 2018, 05:36:52 AM »

Hey guys, just got my new saber today. It was a mystery saber, specifically an Electrum Wind with premium sound and rechargable batteries, however I'm having some troubles accessing the soundboard. I'm assuming I have obsidian v3 sound because I cannot cycle sounds through the saber itself, so I tried installing the mac version of the launcher and I want to go ahead and plug my saber in to change fonts, but I'm not sure if this is the current version of the launcher. What I have is the v2.45 launcher, but this thread says to use the v4 launcher... I just don't know how to access the v4 launcher, and I don't want to plug in my saber because I heard plugging in to old launchers can actually mess up the board. Any help would be appreciated.

I think you're confusing the version number of the Launcher software (v2.45) with the version number of the sound board (v4).  v2.45 is the latest version of the Launcher software (which is known as the "Obsidian v4 Launcher").  And yes, it does work with the v3 sound board.
Logged

- Abrahm
- Sentinel LE v4 (tri-cree AB, Obsidian v4)

Voidwalker
Force Sensitive
*

Force Alignment: 0
Posts: 6


« Reply #286 on: January 12, 2018, 06:50:49 PM »

Yeah, I did confuse those two things. Ended up figuring everything and couldn't be happier with my saber. Thanks for the reply!
Logged

Pages: 1 ... 18 19 [20]   Go Up
Send this topic | Print
Jump to: