Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: 1 ... 7 8 [9] 10 11 ... 13   Go Down
Author Topic: UltraSabers Launcher v2.89 Windows Launcher  (Read 197524 times)
DarthMirage
Knight Lance Corporal
*

Force Alignment: -19
Posts: 44



« Reply #120 on: September 03, 2017, 01:10:02 AM »

Thank you for your reply Mirage. I tried to exhaust all of my options before bothering again. So here's my repro steps.

(EDIT: Further Repro steps + System)
System: Win 10 Current 9.2.2017 High end dev pc (No point in putting specs for this application)

Connected Methods tried.
-Diconnected lightsaber, plugged in lightsaber to pc, turned on
-Plugged into pc with lightsaber on
-Connect/Disconnect, while on/off
-Connected to hub while on/off
-Connected to extension cable while on/off
-Connected through DAW Controller while on/off
-Connected through 3.0 hub, just to check

Computer recognizes device every time, software does not.
I got the newer version. I attempted to connect on USB 3.0,2.0 and even 1.0 via an ancient extension cable. No dice. Does the newer software only work with newer sabers? I've got an Initiate V4 and for the life of me, it just doesn't seem to connect but for once in a blue moon. Does anyone else have this issue? Seriously, quality of the lightsabers are top notch, love them, but the software is pretty Chinese MMORPG.
CHINESE MMORPG LMAO!! I had that problem before I updated, but after wards it connected almost instantaneously, but then took a while to load everything, but as the video tutorial mentions it'll connect faster after it recognizes what's being connected. I'm also using Win7 as an OS and don't know how that affects things. Wish I could help ya more!
Logged

Peace is a lie. There is only Passion.
►ONLY DARK SIDE POINTS PLEASE◄
Arsenal:
-Dark Mantis, Reaper emitter, Large Renegade LE Pommel
-Initiate V4 LE, Catalyst Pommel (no emitter windows)
-Chose One CE
-Dark Initiate V4 LE, Dark Catalyst Pommel (with emitter windows)
-Dark Sentinel, with Yari Pike Extension and Reaper Pommel
-Reaper, with Clawed-Dark Mantis Emitter and Dark Sentinel Pommel
-Doubled-bladed Catalyst
-Aeon V4
-Initiate LE V2
-Crimson Scorpion

Therion Jinn
Knight Commander
*

Force Alignment: -1426
Posts: 4429


May The Force Serve You Well


« Reply #121 on: September 03, 2017, 01:59:37 AM »

Valefor,
One thing I've seen with my machine is that the software will ONLY work if run as Administrator (right click the icon, select 'run as  administrator')
And that only works if you power the saber on before starting the software
Logged


Racona Nova
Knight of the Obsidian Order
Moderator
Knight Commander
*****

Force Alignment: 1116
Posts: 4771


There is no good or evil....there's only power!


« Reply #122 on: September 04, 2017, 09:49:14 AM »

That makes sense though. You're using a front 2.0 point which is likely tied to hardware bound to the case, or that particular board, more than a modern 2.0 system. Most newer PCs won't have that, and won't have the legacy drivers required to run this. Ultrasabers really needs to update their stuff, it's borderline false advertising.

Well, I have a more or less completely new PC - new MB, new drivers etc. Only the case is the same. The ports on the case are connected to the board, but you may be right, the legacy could be a problem on some boards and BIOS. Maybe I'm lucky, having an AMD BIOS and MB which supports legacy drivers better than others...

I'm with you, US should find a solution for that since the problem becomes bigger with more and more users switching to Win X...
Logged

Sig by Master Nero
Phantasm v3 LE (Obs v3) - AB w/ FoC AS---Manticore (Obs v3) - BR w/ FoC AS (QD)---Archon v2.1 (Obs v3) - RGBW Emerald

Therion Jinn
Knight Commander
*

Force Alignment: -1426
Posts: 4429


May The Force Serve You Well


« Reply #123 on: September 04, 2017, 04:25:13 PM »

I'd also make sure you have at least one USB 2.0 port to plug into.
Mine HATES trying to connect through the USB 3.0 port
Logged


Valefor
Knight Apprentice
*

Force Alignment: 2
Posts: 29


« Reply #124 on: September 05, 2017, 03:06:42 PM »

Thank you all for your replies. Unfortunately I've tried all the steps mentioned. 2.0 port, ect.

As to your question Mirage, OS matters a ton. Different operating systems have different ways they interpret Human Interface Devices. And windows XP's drivers were retired as legacy in 2015. So, any system past 2015 will not have legacy drivers available. Ultrasabers unfortunately must update their software or they risk alienating all future customers from use of their software. It's a simple fact of life. I wish I could get away with letting my software go legacy, but I'd lose my job frankly Smiley
Logged

Therion Jinn
Knight Commander
*

Force Alignment: -1426
Posts: 4429


May The Force Serve You Well


« Reply #125 on: September 06, 2017, 02:53:41 AM »

My machine was upgraded from 8 to 10, likely why I can get it to work
Logged


Valefor
Knight Apprentice
*

Force Alignment: 2
Posts: 29


« Reply #126 on: September 06, 2017, 04:02:11 PM »

OK! Got it to work. Here's the solution for anyone that has this situation.

- The issue is the board doesn't have enough power to register as a USB device for 3.0, and in 2.0 it barely qualifies.
- The solution is to do FRESH BATTERIES right away, then put it into a self powered USB. It recognized it instantly.

I had to test it with networking hardware tools and found it was putting out so little that it wasn't picking up. A watch battery on the board could have resolved this. But that's the issue. Perhaps later sound boards will have connective power. Thank you all for your assistance, and I hope this information helps someone else!
Logged

DarthMirage
Knight Lance Corporal
*

Force Alignment: -19
Posts: 44



« Reply #127 on: September 06, 2017, 04:07:57 PM »

Thank you all for your replies. Unfortunately I've tried all the steps mentioned. 2.0 port, ect.

As to your question Mirage, OS matters a ton. Different operating systems have different ways they interpret Human Interface Devices. And windows XP's drivers were retired as legacy in 2015. So, any system past 2015 will not have legacy drivers available. Ultrasabers unfortunately must update their software or they risk alienating all future customers from use of their software. It's a simple fact of life. I wish I could get away with letting my software go legacy, but I'd lose my job frankly Smiley
Thank you for the information and reply back! Glad to hear you managed to fix the problem!
Logged

Peace is a lie. There is only Passion.
►ONLY DARK SIDE POINTS PLEASE◄
Arsenal:
-Dark Mantis, Reaper emitter, Large Renegade LE Pommel
-Initiate V4 LE, Catalyst Pommel (no emitter windows)
-Chose One CE
-Dark Initiate V4 LE, Dark Catalyst Pommel (with emitter windows)
-Dark Sentinel, with Yari Pike Extension and Reaper Pommel
-Reaper, with Clawed-Dark Mantis Emitter and Dark Sentinel Pommel
-Doubled-bladed Catalyst
-Aeon V4
-Initiate LE V2
-Crimson Scorpion

Therion Jinn
Knight Commander
*

Force Alignment: -1426
Posts: 4429


May The Force Serve You Well


« Reply #128 on: September 07, 2017, 02:45:47 AM »

Good to hear you found a fix
Logged


dark_dreamer
Force Sensitive
*

Force Alignment: 0
Posts: 4


« Reply #129 on: December 13, 2017, 07:38:44 AM »

I am a little confused.
I have the emerald driver and I have downloaded app for windows from the first post of this thread.
it is announced as v4. While installing it says version 2.4.2
and after  update it reports as v 1.0.3

which is the real version ?

and is this the real thread to download the recent app ?

because I have another app installed on my pc previously. it is named "obsidian launcher" and reports version 3.x

which is the correct app  ?
Logged

DarthMirage
Knight Lance Corporal
*

Force Alignment: -19
Posts: 44



« Reply #130 on: December 25, 2017, 11:02:44 PM »

I am a little confused.
I have the emerald driver and I have downloaded app for windows from the first post of this thread.
it is announced as v4. While installing it says version 2.4.2
and after  update it reports as v 1.0.3

which is the real version ?

and is this the real thread to download the recent app ?

because I have another app installed on my pc previously. it is named "obsidian launcher" and reports version 3.x

which is the correct app  ?
Did you follow the instructions to update the software?
-Close program
-Go to the folder you installed the program
-Look for the application called "MaintenanceTool"
-Run as Administrator
-Choose update components
-Then hit next and follow the prompts
You may encounter some files that can't be removed, just hit ignore.
Just finished updating myself and it says it's at 2.42, the current version.
Logged

Peace is a lie. There is only Passion.
►ONLY DARK SIDE POINTS PLEASE◄
Arsenal:
-Dark Mantis, Reaper emitter, Large Renegade LE Pommel
-Initiate V4 LE, Catalyst Pommel (no emitter windows)
-Chose One CE
-Dark Initiate V4 LE, Dark Catalyst Pommel (with emitter windows)
-Dark Sentinel, with Yari Pike Extension and Reaper Pommel
-Reaper, with Clawed-Dark Mantis Emitter and Dark Sentinel Pommel
-Doubled-bladed Catalyst
-Aeon V4
-Initiate LE V2
-Crimson Scorpion

Snipah
Knight Lance Corporal
*

Force Alignment: -21
Posts: 57



WWW
« Reply #131 on: January 18, 2018, 02:56:02 AM »

I'm interested to know why you have to go that route?
An enhancement would be-----
~pop up window~
There is an update to this software!
Do you wish to update Yes/No
Hit yes program updates and restarts?Huh??
Logged

Armoury:
Dark Initiate v4 - Tri Blazing Red
Emperor's Hand - Violet Amethyst

Force FX - Luke Skywalker
Force FX - Darth Vader

diablogod
Knight Lance Corporal
*

Force Alignment: -27
Posts: 42



« Reply #132 on: February 17, 2018, 04:46:49 PM »

i have the raven with the v3 soundboard, i know only 1 font can be on bank but how do i change that fon in launcher wont let me upload any other fonts
Logged

Rapine
Honoured Recipient of the Warlord Order
SaberForum.Com Moderator
Knight Commander
*****

Force Alignment: -3020
Posts: 7792


Always scanning the horizon...


« Reply #133 on: February 17, 2018, 04:56:09 PM »

You need to download a new font first diablogod. Smiley

Save in a good spot on your PC, then find it with the launcher when it's time.

You can start here: http://www.saberforum.com/index.php?board=36.0  US has some good ones, but there are also a lot of good ones made by members here. Smiley
Logged

"The thing that always drives me hazy, is wondering whether it's them or me who's crazy." ~ A. Einstein

diablogod
Knight Lance Corporal
*

Force Alignment: -27
Posts: 42



« Reply #134 on: February 17, 2018, 05:12:25 PM »

ive saved a font but when i try to put it in the launcher nothing happens
Logged

Pages: 1 ... 7 8 [9] 10 11 ... 13   Go Up
Send this topic | Print
Jump to: