Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: [1]   Go Down
Author Topic: Cant connect via Windows 10 or 8.1  (Read 4903 times)
DrestonF1
Force Sensitive
*

Force Alignment: 0
Posts: 4



« on: October 19, 2015, 11:33:24 PM »

Greetings all.  First saber, many issues.  Recharge port doesn't seem to work but that has its own post.  

Problem:  
I can't connect my saber to the UltraSabers launcher.

Data:
Saber: Dark War Glaive with sound, emerald driver, V4 Obsidian
Laptop: Windows 10, tried direct USB and via old Belkin USB hub
Desktop: Windows 8.1, tried direct USB and via old Belkin USB hub
Methods:  I have tried every permutation of powering on saber first, saber last, unplug usb with saber on, with saber off, restart Launcher first/last, installed launcher as administrator, ran program as administrator.

Result:
USB device not recognized.  The very first time I installed the Launcher on the laptop, I was able to access the sound board.  Then tried the LED board and USB not recognized and forever again was unrecognized for both boards.  I have read so many posts and none seem to be exactly my issue.  Most are fixed with a USB hub.  I shall continue searching while I wait your expert opinions.

Please help!  I don't want to be soured on my first UltraSaber so quickly.  
Thanks.
Logged

Antron007
Knight Ensign
*

Force Alignment: 35
Posts: 198


Give light or dark points and let the force decide


« Reply #1 on: November 13, 2015, 12:17:30 PM »

Check out this thread

http://www.saberforum.com/index.php?topic=25028.0

The steps I have to take with Windows 10 are in there as well for some good info from Obi-Juan that might work for you as well.
Logged

Sabers I own: Customized Archon V3* (Emerald w/ v4 Sound), Ordered with PYO, Currently set to GB; Customized Dark Initiate LE v4 (Stunt) CG; Apprentice V4 (Grab Bag w/ li-ion) BR; Graflex SE (Emerald w/ v4 Sound), Ordered with GB, Currently set to GB; Menace SE* (DIY); TBD;

*Hilts I swap the electronics between.

Sabers/Hilts I want: Guardian, Chosen One SE, Consular, Dark Omen, the rest of them in no particular order.

"If you don't see me somewhere out there in the Galaxy slaying some form of evil, it's because I'm sneaking up on you right now." - Antron Mok

gig_nova
Force Sensitive
*

Force Alignment: 0
Posts: 2


« Reply #2 on: December 28, 2015, 10:16:45 AM »

I get pretty much the same issue.  New Saber for Christmas....USB 3 ports and windows 10.  Windows 10 is new so I can maybe understand issues there, but usb 3 has been out for awhile now. Will try suggestions in the other thread, though I have tried many already.

Nova
Logged

Antron007
Knight Ensign
*

Force Alignment: 35
Posts: 198


Give light or dark points and let the force decide


« Reply #3 on: December 28, 2015, 11:51:12 AM »

I'm sure you've tried but I feel the need to mention that you should be sure your batteries are fully charged.

Sent from my SM-G920V using Tapatalk

Logged

Sabers I own: Customized Archon V3* (Emerald w/ v4 Sound), Ordered with PYO, Currently set to GB; Customized Dark Initiate LE v4 (Stunt) CG; Apprentice V4 (Grab Bag w/ li-ion) BR; Graflex SE (Emerald w/ v4 Sound), Ordered with GB, Currently set to GB; Menace SE* (DIY); TBD;

*Hilts I swap the electronics between.

Sabers/Hilts I want: Guardian, Chosen One SE, Consular, Dark Omen, the rest of them in no particular order.

"If you don't see me somewhere out there in the Galaxy slaying some form of evil, it's because I'm sneaking up on you right now." - Antron Mok

kingbing1989
Force Sensitive
*

Force Alignment: 0
Posts: 5


« Reply #4 on: July 17, 2020, 04:06:57 PM »

I just bought two Dark Apprentice LE v5 with Obsidian Sound Boards v4. I installed the newest software for the Obsidian and Emerald control/customization. I ran the installation as administrator. I turned the saber on. I connected the USB Mini cable into the PC into a 2.0 port and then proceeded to plug it into the saber. The Win10 installation recognizes the device as "Light Saber" and then ran the Ultrasaber software as admin. The saber did not connect to the software. I tried the same thing on my laptop - every step and still nothing. The laptop is also Win10 x64, but has no USB 2.0 ports. The cable is not from Ultrasabers, but is fully functional and each end has continuity with a multi-meter. I have tried to uninstall the device in Device Manager and plug-in again and still no connection. I have tried to re-install after cleaning registry and re-installing with admin rights, still no connection. Anyone have any opinions for my issues?
Logged

Sakura No Kaze
Knight Commander
*

Force Alignment: -175
Posts: 621


DS if I've earned a point.


« Reply #5 on: July 19, 2020, 11:35:24 AM »

First, if you haven't already, check out the thread linked in Antron007's post above. It gives good information that has worked for others.

Second, while the cable shows continuity at both ends, make sure that's it's data capable, and not just charging capable.

Third, I think I figured out what the issue probably is.

I just bought two Dark Apprentice LE v5 with Obsidian Sound Boards v4. I installed the newest software for the Obsidian and Emerald control/customization. I ran the installation as administrator. I turned the saber on. I connected the USB Mini cable into the PC into a 2.0 port and then proceeded to plug it into the saber. The Win10 installation recognizes the device as "Light Saber" and then ran the Ultrasaber software as admin. The saber did not connect to the software.

You need to have the Emerald/Obsidian software already running when you connect the saber. It usually won't detect the saber if it's already there, only if it's "new" i.e. plugged in after the software is running.

So, in order, probably should do on your PC so you can use the USB 2.0 ports:

0) Make sure your batteries are fully charged, or the saber is plugged into it's recharge port (if you have one). Both the software and the saber REALLY don't like it if the saber shuts off while you're changing settings/sound fonts.
1) Start Emerald/Obsidian software (run as admin).
2) Turn on Lightsaber.
3) Connect Lightsaber to Computer with USB mini cable.

That should work. Hopefully.

Logged

Give a person an answer to their question and they get your answer. Teach a person how to use the forum Search function, and they get everyone's answer.
---------------------------------------------------------------
"My battery is low and it's getting dark" ~Final message from the Mars Opportunity rover, after exceeding it's 90 day mission plan by 14+ years.

kingbing1989
Force Sensitive
*

Force Alignment: 0
Posts: 5


« Reply #6 on: July 19, 2020, 03:10:34 PM »

I did and it worked, to a point. I've posted the issue that came up when the saber connected in that discussion.
Logged

Pages: [1]   Go Up
Send this topic | Print
Jump to: