Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: [1]   Go Down
Author Topic: Sound levels and the Diamond board  (Read 153 times)
Akheron
Knight Sergeant
*

Force Alignment: 16
Posts: 82


"The middle path is the way to wisdom."


« on: December 05, 2017, 09:27:19 PM »

I've been converting a plecter font for use with my diamond board, and I can't seem to get the idle hum to match other sounds, such as ignition or swings.

I've tried manually reducing the level of the hum sound in Audacity, and then reloading it on the board, but it's always at the same volume. In fact, when I look at the waveform in the launcher after writing, testing, and reconnecting, it looks like it has been amplified, like the board automatically applies some kind of maximization to the sound.

Has anyone else dealt with this issue, or know how to fix it? It sounds pretty bad, especially when the volume jumps after every swing.
Logged

Ultrasabers what I own:

Dark Initiate LE V4 - Diamond
Dark Apprentice LE V4 - Diamond
Bellicose - Emerald, ObsidianV4
Apprentice V4 - Tri-Guardian Blue, ObsidianV4
Crimson Scorpion - Blazing Red, Silver FoC, ObsidianV4 <- Raffle Prize Smiley

EvilOttoJr
Knight Aspirant
*

Force Alignment: 0
Posts: 20


« Reply #1 on: December 06, 2017, 09:35:31 AM »

I've been converting a plecter font for use with my diamond board, and I can't seem to get the idle hum to match other sounds, such as ignition or swings.

I've tried manually reducing the level of the hum sound in Audacity, and then reloading it on the board, but it's always at the same volume. In fact, when I look at the waveform in the launcher after writing, testing, and reconnecting, it looks like it has been amplified, like the board automatically applies some kind of maximization to the sound.

Has anyone else dealt with this issue, or know how to fix it? It sounds pretty bad, especially when the volume jumps after every swing.


I'm dealing with this exact same issue not just with converting Plecter fonts (e.g. KotOR by Machinimax), but even with some that were natively written for Obsidian/Diamond (e.g. Maul by Aldar Beedo). I just posted a thread on it here: http://www.saberforum.com/index.php?topic=36626.0 and then I saw your thread.

Yeah, it sounds really bad. I didn't think to check the waveform on the font after the board; you say it's actually amplifying the files themselves after uploading? Interesting.

Apparently this was a known issue on Diamond back in about April (thread here: http://www.saberforum.com/index.php?topic=34797.0), and also known that the "Effect Volume" slider in the effects wizard works when you hit "test" but does nothing after the font is written to board. This was apparently a bug that was supposed to be fixed in a subsequent update but never was.

Can someone from RSX weigh in on this? Your "bug" may be a result of whatever normalizes all the sound volume in your font when it's written to board. The volume slider may work just fine but then the result is undone by the normalization. Hoping this is fixed very soon. Let me know if you'd like any more info.
Logged

Akheron
Knight Sergeant
*

Force Alignment: 16
Posts: 82


"The middle path is the way to wisdom."


« Reply #2 on: December 06, 2017, 10:56:29 PM »

Yeah, I made the mistake of posting first and searching afterwards, lol. I see others are having the same experience as myself.

I like the updates RSX has done so far, I hope they can tackle this issue soon.
Logged

Ultrasabers what I own:

Dark Initiate LE V4 - Diamond
Dark Apprentice LE V4 - Diamond
Bellicose - Emerald, ObsidianV4
Apprentice V4 - Tri-Guardian Blue, ObsidianV4
Crimson Scorpion - Blazing Red, Silver FoC, ObsidianV4 <- Raffle Prize Smiley

EvilOttoJr
Knight Aspirant
*

Force Alignment: 0
Posts: 20


« Reply #3 on: December 07, 2017, 01:05:21 AM »

Yeah, I made the mistake of posting first and searching afterwards
Nah, that was my bad, actually; you had posted the day before I did. Also in the correct child board  \_(ツ)_/

Yeah, I gotta say, overall this board is pretty fun (especially if you've got the lighted AV switch which is a blast to program into your light effects), which is why I'm really hoping we can get these sound issues dealt with. That's the one thing holding it back.
Logged

RSX Engineering
Knight Sergeant
*

Force Alignment: 45
Posts: 102



WWW
« Reply #4 on: December 07, 2017, 06:30:30 AM »

Hi everyone,

the 2.41 update contains various bug fixes, meaning that the volume setting in the effect editor works now properly. You can have a look in the User Manual located in the Launcher's main tab, under Resources or  http://rsxengineering.com/saber_resources/Diamond_UserManual.pdf (pages 32 , 33)for more details on the topic regarding sound normalization.

Cheers,
Adrian
Logged

EvilOttoJr
Knight Aspirant
*

Force Alignment: 0
Posts: 20


« Reply #5 on: December 07, 2017, 06:47:26 AM »

Hi everyone,

the 2.41 update contains various bug fixes, meaning that the volume setting in the effect editor works now properly. You can have a look in the User Manual located in the Launcher's main tab, under Resources or  http://rsxengineering.com/saber_resources/Diamond_UserManual.pdf (pages 32 , 33)for more details on the topic regarding sound normalization.

Cheers,
Adrian


I am already using version 2.41, firmware version 240, so unless you've updated it in the last 12 hours, I am current, but still have the issue. As I said before, the volume setting only works on the saber when you hit "Test" with the saber connected to the launcher. When that is written to the board, however, and then disconnected, the actual volume when using the saber does not change. Plugging the saber back in shows the volume slider in the position you left it, but the playback volume is unchanged.

EDIT: clarification: it seems like the normalization is being applied *after* the volume changes we make in the effects editor, hence nullifying any changes we make with the volume slider.

Akheron, are you also running the latest launcher version/Diamond firmware? I'm assuming yes but just want to be sure.
Logged

EvilOttoJr
Knight Aspirant
*

Force Alignment: 0
Posts: 20


« Reply #6 on: December 07, 2017, 07:06:16 AM »

What we really need is for normalization to be a checkbox option that users can enable/disable on a per-font basis. I understand the need to level out the volume from various sources, but the fact is that a lot of font makers are already balancing the sounds in their 3rd party editors (which you have to use to make soundfonts anyways as the idle hum needs to be mixed into the background of every effect for a smooth transition since sounds aren't mixed on-board), and so the normalization actually ruins that for any fonts that are already balanced correctly (most are) and means the user has to do more work editing the volume of every single clip in the effects editor to rebalance them. Which, as we have discovered, doesn't seem to work correctly anyways.
Logged

RSX Engineering
Knight Sergeant
*

Force Alignment: 45
Posts: 102



WWW
« Reply #7 on: December 07, 2017, 07:27:41 AM »

Thank you for the clarification, extra info is always useful. It appears that there's a fault in the Launcher and we're working to fix it ASAP.
Thanks again for bringing it to our attention.

Cheers,
Adrian
Logged

RSX Engineering
Knight Sergeant
*

Force Alignment: 45
Posts: 102



WWW
« Reply #8 on: December 07, 2017, 07:47:23 AM »

There is a workaround for setting the effect sound volume, which requires more clicks (until we release the update fixing the issue):
Using the advanced font wizard, you do the following:
1. Delete the sound file from the effect.
2. Write to board.
3. Add the sound file to the effect.
4. Set the preferred level of volume
5. Write to board.

Let us know how it works.
Cheers,
Adrian
Logged

EvilOttoJr
Knight Aspirant
*

Force Alignment: 0
Posts: 20


« Reply #9 on: December 07, 2017, 08:13:07 AM »

Thanks, Adrian! Good to know that the issue is being looked into; let me know if I can be of any more help.

Hopefully it's a simple fix. I'll try the workaround in a few hours when I get home. I still think user-toggled normalization would be incredibly useful, as many (if not most) soundfonts simply don't need it at all and are much better off without it.

That's probably the best thing about the Diamond is that you can do software and firmware updates if issues are found or users want something different. A lot of boards, once they're flashed, they're flashed, so it's good to see that not only can things be fixed if need be, but also that you guys are receptive to user input (e.g., shorter menus) and able to implement it.
Logged

BatMike90
Knight Commander
*

Force Alignment: -305
Posts: 1114


Dark (Knight) Side Points.


« Reply #10 on: December 07, 2017, 07:39:50 PM »

Following this thread closely.
Logged

My Sabers: Aeon LE V2 / Archon V3.1 / Bellicose / Dark Apprentice V4 (x2) / Dark Prophecy V3 (x5) / Emperor's Hand / Graflex SE / Initiate LE V2 / Renegade LE / Scorpion (x2) / Sentinel LE V4
What's Next/Wishlist: Upgrading current sabers.
Cosplay Alias: Darth Kruelik/Mykal Kruelik.

Lady Agana Kath
Knight Commander
*

Force Alignment: -368
Posts: 960


I do not fear the Darkness for it is my ally


« Reply #11 on: December 08, 2017, 07:55:00 AM »

Ditto
Logged

Aeon v2, Archon v2, Chosen One CE, Consular, Dark Apprentice LE v4, Dark Initiate v4, Dark Initiate LE v4, Dark Sentinel v4, Dark War Glaive, Flamberge v2, Initiate v4, Manticore, Sentinel v4

Darkside Points Please

Akheron
Knight Sergeant
*

Force Alignment: 16
Posts: 82


"The middle path is the way to wisdom."


« Reply #12 on: December 09, 2017, 11:15:04 PM »

There is a workaround for setting the effect sound volume, which requires more clicks (until we release the update fixing the issue):
Using the advanced font wizard, you do the following:
1. Delete the sound file from the effect.
2. Write to board.
3. Add the sound file to the effect.
4. Set the preferred level of volume
5. Write to board.

Let us know how it works.
Cheers,
Adrian

Thanks for the tip, it's working for me now!

I was able to smooth out one of my fonts like this, but in another, the hum was still too loud with the volume set to minimal. I totally agree with everything EvilOttoJr said about a toggle for the normalization.
Logged

Ultrasabers what I own:

Dark Initiate LE V4 - Diamond
Dark Apprentice LE V4 - Diamond
Bellicose - Emerald, ObsidianV4
Apprentice V4 - Tri-Guardian Blue, ObsidianV4
Crimson Scorpion - Blazing Red, Silver FoC, ObsidianV4 <- Raffle Prize Smiley

Pages: [1]   Go Up
Send this topic | Print
Jump to: