Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: [1] 2 3   Go Down
Author Topic: [OLDER SOUNDBOARDS ONLY] Obsidian Launcher - V2.2.2  (Read 10577 times)
Ultra
Executor of the Obsidian Order
Administrator
Knight Commander
******

Force Alignment: 342
Posts: 1535



WWW
« on: November 04, 2011, 11:55:19 AM »

THIS IS FOR OLDER VERSIONS OF THE SOUNDBOARD PURCHASED BEFORE 2013

The Obsidian Launcher, version 2.2.2, is available for free download.  The direct download link is below:
You can download a copy of the Obsidian USB Launcher 2.2.2 & .LSU Convertor program below:





ALWAYS uninstall your old version of Obsidian Launcher before installing a new one!!

Do NOT use version 2.0.1 and do NOT use version 1.x.x.  Please be sure to use version 2.2.2.




Here is a video on how to install the newest version of the Launcher:


Small | Large






Here is a video on how to upload soundfonts with the Obsidian Launcher:


Small | Large





This version, and later versions, of the Obsidian Launcher is REQUIRED for use with the new Obsidian XT boards which feature Flash on Clash™  If you use an old launcher with these new boards, it will not function properly, so PLEASE install this new version!

The new launcher solves a few problems, the biggest of which is the CRC file copy error some people were getting when trying to load large font files.

We at Ultra Sabers are always striving to improve our products and offer support to our customers after the sale.  This new release of our launcher with requested bug fixes is further testimony of that spirit.

Obsidian, Obsidian Launcher, Ultra Sabers, and Flash on Clash are trademarks or service marks of Ultra Sabers LLC.
« Last Edit: March 04, 2014, 09:15:59 AM by Deep » Logged


Qui-Tom Helms
Knight Commander
*

Force Alignment: 139
Posts: 1774


« Reply #1 on: November 04, 2011, 12:07:23 PM »

Can this newer version be used with the standard obsidian boards?
Logged

=====================================================================
Zartom   Socerer (Healer)                             Qui-Tom  Sage (Healer)
Trenok   Bounty Hunter (Powertech)               Vartom   Knight (Sentinel)
=====================================================================

Ultra
Executor of the Obsidian Order
Administrator
Knight Commander
******

Force Alignment: 342
Posts: 1535



WWW
« Reply #2 on: November 04, 2011, 12:26:06 PM »

Can this newer version be used with the standard obsidian boards?

Yes, and it should be.
Logged


Vex
Knight Commander
*

Force Alignment: -374
Posts: 1723



« Reply #3 on: November 04, 2011, 12:54:47 PM »

Ultra you take customization to another level, thank you!!
Logged


dark side points please

Qui-Tom Helms
Knight Commander
*

Force Alignment: 139
Posts: 1774


« Reply #4 on: November 04, 2011, 12:58:41 PM »

Got it to work...so no one else should have any problems Cheesy Cheesy Cheesy
Logged

=====================================================================
Zartom   Socerer (Healer)                             Qui-Tom  Sage (Healer)
Trenok   Bounty Hunter (Powertech)               Vartom   Knight (Sentinel)
=====================================================================

Darth Wraith
Knight Commander
*

Force Alignment: -159
Posts: 1751


Founder of The Grey Sith Order


WWW
« Reply #5 on: November 04, 2011, 11:05:21 PM »

Well... I Got A Crap Ton of Error Messages (I Am Running This On Windows 7, So That Might Be Why...)

However, Everything Seems To Be Working Fine... I'll Have To Wait Till I Get My First Obsidian Saber (Going To Be My Overlord Wink!!!) Before I Can Tell For Sure If Everything Is Functioning Correctly Wink!!!

Thank You Ultra and Team Wink!!!  I Have A Couple of "Bigger" Custom LSU Files That I Am Going To Want To Try and Use Wink!!!  So Hopefully This Will Eliminate Any Issues That I Might Have Had  Cool
Logged



I Am the Lord of Shadow!!! Even as I am Enveloped by Darkness... So to Shall I be Embraced by the Light!!!!!

ewanhuzarmie
Knight Lance Corporal
*

Force Alignment: 8
Posts: 56


WWW
« Reply #6 on: November 05, 2011, 12:13:17 AM »

I received many "The file you are trying to replace is older than what is installed" dialogs, and a few errors when it tried to run the regsvr on the previously installed files. As long as you keep your existing files, you will be fine. The regsvr calls are erroring out because the files are already registered with the system.
Logged


Qui-Tom Helms
Knight Commander
*

Force Alignment: 139
Posts: 1774


« Reply #7 on: November 05, 2011, 10:51:18 PM »

I got windows 7 as well, and got a couple error messages myself including one for the file itircl.dll, but the program downloaded, installed and worked fine.
Logged

=====================================================================
Zartom   Socerer (Healer)                             Qui-Tom  Sage (Healer)
Trenok   Bounty Hunter (Powertech)               Vartom   Knight (Sentinel)
=====================================================================

Darth Mortis
Knight Apprentice
*

Force Alignment: 0
Posts: 45



« Reply #8 on: November 05, 2011, 11:17:56 PM »

When I installed this new Obsidian launcher I got an error about my system32\itircl.dll ; system32\itss.dll ; and system32\ hhctrl.ocx when I installed the program. It worked but when I hit the update sound files button it said some error about not having an internet connection when I know for a fact that I did. How do I fix these problems?
Logged

Ultra
Executor of the Obsidian Order
Administrator
Knight Commander
******

Force Alignment: 342
Posts: 1535



WWW
« Reply #9 on: November 05, 2011, 11:47:18 PM »

When I installed this new Obsidian launcher I got an error about my system32\itircl.dll ; system32\itss.dll ; and system32\ hhctrl.ocx when I installed the program. It worked but when I hit the update sound files button it said some error about not having an internet connection when I know for a fact that I did. How do I fix these problems?

you dont need to use the update sound files button.  That button is for a feature not implemented yet.
Logged


Icke10
Knight Aspirant
*

Force Alignment: 1
Posts: 23


« Reply #10 on: November 06, 2011, 07:39:17 AM »

Ok, new version is working good. But where can I download the LSU convertor program now ? Can't find a link anymore...
Logged

Darth Gekido
Knight Major
*

Force Alignment: -75
Posts: 423


Ronin Sith Marauder


« Reply #11 on: November 06, 2011, 11:31:45 AM »

Thank you, Ultra! The new Obsidian Launcher works perfectly. Previously, I was experiencing the same problems as AerykGunn and attempting to follow the same steps to correct the issue. The next day, however, there was a new post with the new launcher. Instant success, and my Bellicose is now configured just the way I want it (Sith font, of course Grin) and it sounds AWESOME! You are indeed the master.
Logged

"Honor is a fool's prize... and glory is of no use to the dead."
      "Mizz'ri"-FO Bellicose, Obsidian, Long Grooves
      "Excrucio"-DVA Prophecy V3, Obsidian, Silver FoC
      "BMF"-Hasbro Force FX Mace Windu
      "Pain"-Anakin ROTS US FX, VA 
Dark Side points, please

Zren Tobas
Knight Commander
*

Force Alignment: -271
Posts: 5869


[Give Light Side Points!] [Give Dark Side Points!]


« Reply #12 on: November 17, 2011, 02:20:15 PM »

Nice. But the same thing still keeps happening. "Error accored while registering the file" so on and so on. Why does this keep happening? Is it cause I actually need to get an Obsidian saber and plug the sound board into the computer before it fully downloads?
Logged

My sabers: Bellicose GB Obsidian, Overlord AB

Next sabers: New US Prototype saber Aeon version GB, Dominix version CG for bro, Archon V2.1 SRD

The Force will be with you. Always. -Obi-wan Kenobi-

Master Artorius Vidnyl
Resident Master
Forum Elder
Knight Commander
*****

Force Alignment: 746
Posts: 2169


Suns of the Force


« Reply #13 on: November 17, 2011, 02:30:09 PM »

Nice. But the same thing still keeps happening. "Error accored while registering the file" so on and so on. Why does this keep happening? Is it cause I actually need to get an Obsidian saber and plug the sound board into the computer before it fully downloads?
Are you getting this before the initial download completes or when you try to run the program?

To answer you question you do not need a saber to complete the download.  If you haven't uninstalled the old version COMPLETELY (as in go to control panel -> Add/Remove programs and choose the Obsidian software) this could contribute to your problem.

More details and we'll see what we can do for you.
Logged


Zren Tobas
Knight Commander
*

Force Alignment: -271
Posts: 5869


[Give Light Side Points!] [Give Dark Side Points!]


« Reply #14 on: November 17, 2011, 02:44:46 PM »

Ohh I get it. I wasn't unzipping the original folder and putting the stuff into a new folder. Dumb me. xp
Logged

My sabers: Bellicose GB Obsidian, Overlord AB

Next sabers: New US Prototype saber Aeon version GB, Dominix version CG for bro, Archon V2.1 SRD

The Force will be with you. Always. -Obi-wan Kenobi-

Pages: [1] 2 3   Go Up
Send this topic | Print
Jump to: