Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: [1]   Go Down
Author Topic: Help!! :(  (Read 73 times)
Rule0F2
Force Sensitive
*

Force Alignment: -1
Posts: 5



« on: January 10, 2019, 09:37:17 PM »

Hey guys,

I ordered a dark savior with obsidian lite sound board last month. I have never dropped it and it is used mostly for a display piece. I turned it on today and after a few seconds it shut off and said "obsidian" while shutting down. Upon checking the batteries I noticed that there was electrical tape wrapped around the whole battery back and sound board. Is the saber shutting down due to low batteries or is this some kind of defect? Any help you could offer would be greatly appreciated.

May the force be with you always,

   Kevin
Logged

Malik Thanewulf
Knight Commander
*

Force Alignment: -235
Posts: 948


Grey Jedi with MAJOR Sith-like tendencies


« Reply #1 on: January 10, 2019, 04:17:24 PM »

Calm down. It could just be your batteries running down. The electric tape is pretty much how the sound board usually comes,  so no worries there.  Try new batteries 1st. Make sure they aren't the heavy duty. They can overpower the board. That's what I was told when it happened to me. If that doesn't fix it, contact Marlena at Ultrasabers. She's pretty awesome. FYI  I couldn't get my to work, so they had me send the saber back to them. They're fixing it for me. No problem.  Bottom line: don't be worried, they will make it right.
Logged

My Collection: Emperor's Hand,Guardian, Scorpion, Dominix LE v4, Dark Initiate LE v4, Lost Grey, Fulcrum,Spectre, Azure Butcher, Raven, Crimson Menace, Bellicose

Wish list:  Azure Dorinian, Monarch (nickle plated),  Dark Shock, Crimson Savior.

Rapine
Honoured Recipient of the Warlord Order
SaberForum.Com Moderator
Knight Commander
*****

Force Alignment: -2833
Posts: 8459


Always scanning the horizon...


« Reply #2 on: January 11, 2019, 05:03:43 AM »

Hey there Rule0F2,

The battery sleds for the LITE boards (4xAAA) are kind of loose, and need a bit of extra something to hold the batteries in place.  Hence the tape.

The "Obsidian" sound you heard was the "boot" sound.  It plays each time the board is "awakened", so your batteries re-connected at that time.

Try new batteries, and be sure to wrap them nice and tightly with that tape, or something. 

If that's not it, you may indeed have a defect, and need to send it in.  It will be under warranty though...
Logged

"The thing that always drives me hazy, is wondering whether it's them or me who's crazy." ~ A. Einstein

Infinit01
Knight Commander
*

Force Alignment: 1807
Posts: 7748


Grey Assassin


« Reply #3 on: January 11, 2019, 05:53:00 AM »

What Rapine said. The battery holder for the AAA batteries are pretty brittle and will flex rather easily making the batteries slide out enough to where the saber shuts off. I place electrical tape on mine and make sure that you tightly secure it so it won't pop out.  So swap out the batteries with new ones and use electrical tape to secure the new ones onto the battery pack.
Logged



Karmack
Knight Commander
*

Force Alignment: 753
Posts: 3396


Light side points please.


« Reply #4 on: January 11, 2019, 12:22:56 PM »

Just chiming in: The behavior you describe is typical of end-of-life batteries.  The tape is, as already stated, an attempt to keep the batteries in the chassis nice and snug.   Just unwrap the tape and replace the AAA batteries, it should correct the issue.
Logged

signature picture by DarthScrub

Master Singer of the Mak'Tor

Pages: [1]   Go Up
Send this topic | Print
Jump to: