Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: [1]   Go Down
Author Topic: Emerald saber problem  (Read 697 times)
Joshsteel99
Force Sensitive
*

Force Alignment: 0
Posts: 6


« on: February 02, 2020, 02:10:30 PM »

Ok, so recieved my sentinal v5 saber with emerald driver no sound today, it was was set to artic blue  for default, me and my siblings were waving it around for a while. I had took my eyes of my sister who was playing with it, then all of a sudden the color went from artic blue to consular green.I was puzzled how it was changed without going to the emerald driver software. I'm currently not able to use a computer to check and see if I can change the color back, but I wanted to know if theres a specific button press or something to change the color, or am I looking at a color short, like I've lost the blue led or something(hoping that isnt so).
Logged

Cyclops942
Knight Commander
*

Force Alignment: 477
Posts: 2793


ASU Quidditch -- Brooms up!


« Reply #1 on: February 03, 2020, 10:48:54 AM »

You simply need fresh batteries.  Charge them up, and you’ll be fine.  What you are seeing is your visual “low battery” indicator that is included free of charge with all Arctic Blue blades, even those controlled by Emerald or Diamond boards.

(That’s supposed to be humorous, by the way.  Regardless of the success or failure of the joke, it’s true.)
Logged

Aeon LE v3 in Consular Green
Initiate v2 in Fire Orange
Initiate v2 in Arctic Blue
Dark Apprentice LE v5 in Adegan Silver
Azure Fallen (Diamond) in Dark Violet Amethyst
Frankensaber (Diamond) in Sentinel Yellow fading to Consular Green, with Guardian Blue  FoC — Currently traveling with co-owner

Light Side points preferred, when warranted

Joshsteel99
Force Sensitive
*

Force Alignment: 0
Posts: 6


« Reply #2 on: February 03, 2020, 08:59:07 PM »

Unfortunately that isnt it, my first instinct was to charge the batteries hoping that it was just losing power, but afterwards I came to a fully bright green blade. I finally set up the launcher and tried changing the color to anything with blue combined, all I got was complete green, complete red, and complete white, I cant use blue by itself or combine it with the other colors, i can only mix red, green, and white, which leads me to conclude a short in the blue led, I've already contacted ultrasabers, hopefully I get a reply soon.
Logged

Pages: [1]   Go Up
Send this topic | Print
Jump to: