Click here for lightsabers
  • Home
  • Help
  • Login
  • Register
Pages: 1 ... 9 10 [11]   Go Down
Author Topic: WINDOWS: Ultrasabers Launcher with Diamond Controller UPDATED 01-11-2018  (Read 101387 times)
chalion
Knight Commander
*

Force Alignment: 276
Posts: 1391



« Reply #150 on: December 20, 2019, 02:52:05 PM »

Yes the saber works normally as far as i can tell, i can change fonts, volume up and down works and it charges.

And no, nothing happened when i plugged it in.  To be honest i havent seen that message pop up in a loooong time (installing drivers or detecting new things) and i frequently plug in new things into my ports that work normally without that message.

IF it failed to install or didnt recognize it, it would show up with a yellow triangle with the exclamation mark in the device manager im guessing.... so thats not it either..


If you've tried different cables and different ports (on the computer) and not getting any indication from the lightsaber at all that it's acknowledging the connection (making sure of course the lightsaber is powered on, the launcher is active under admin start up, then plugging the lightsaber in and it did not chime and turn off the led module), then there's likely a problem with the usb connector on the lightsabers Diamond controller card.

My newest lightsaber, The Fallen LE with Diamond controller gives me fits sometimes when I try to connect to the US Launcher. It'll chime every time I plug it in, but fails to connect, unless I try it a few(MANY), times. I'm uploading a video to uTube to show what I mean.

<a href="http://www.youtube.com/watch?v=M-DWDgqT-Ps&amp;feature=youtu.be" target="_blank" class="aeva_link bbc_link new_win">http://www.youtube.com/watch?v=M-DWDgqT-Ps&amp;feature=youtu.be</a>


My thinking here is that my usb cable is going bad. I've used it for my phone and for the most part it's fine, but every so often, I can't connect or I lose data transfer access. This may be why my lightsaber is having problems connecting, but i'm not sure it applies to your problem.
Logged



26 diamond lightsaber and counting

DarthColfax
Force Sensitive
*

Force Alignment: -1
Posts: 3


« Reply #151 on: January 25, 2020, 12:38:11 PM »

Good day.  I upgraded to Mac OS Catalina.  Previous version worked fine.  Downloaded the October version of the MAC launcher.  Uninstalled previous and tried to reinstall the Launcher and get "Can't be Opened".  Anybody else had issues with the launcher in OS Catalina have some pointers?

Update - Figured it out. 
Logged

DarthSyronimus
Knight Arbiter
*

Force Alignment: -40
Posts: 296


WWW
« Reply #152 on: January 27, 2020, 11:25:32 PM »

Hi everyone,

indeed, the current ETA for the 64 bit version for Mac with a few updates is in the middle of September or sooner. We'll also release a corresponding updated version for Windows around the same time (with a few fixes and updates). The current version of the Launcher software is 2.45 the next version will be 2.64 which coincidentally will match with the 64bit release for MAC.

Your RSX Engineering team.

I just made my purchase and thought I'd play with the Launcher on my Win10 box while I wait [patiently]Ö the download seems to have installed v2.45, but the bottom says "Diamond Users! Major Upgrade is Waiting for you"... however, clicking on that box doesn't seem to update me from v2.45 to v2.64.  Also, it seems to have installed the 32bit version instead of the 64bit one.   
Thanks in advance for all help
Logged

Dark Side here, Grey in RPGs
(Order#1 - Ordered 1/27/20 - Arrived 3/12/20)
* Diamond Dominicide for me (died 4/2/20, sent back 5/23/20 for repairs, back in hand and working 6/4/2020)
* Diamond Dark Apprentice LE v5 for the 10yo Padawan
* Stunt Aeon LE v3 - Blazing Red (FreeMysteryBox) for the missus
* Stunt Initiate v2 - Guardian Blue (FreeInitiate) for the 7yo Youngling
(Order #2 - Ordered 5/17/20 - Arrived 9/13/20)
* Stunt Dark Overlord - Consular Green ($75 Mystery Box)
* Yari (Pike) Extension with 16" UEHG
* Silver Vented QR Coupler

Cyclops942
Knight Commander
*

Force Alignment: 482
Posts: 2815


ASU Quidditch -- Brooms up!


« Reply #153 on: January 28, 2020, 06:52:47 PM »

I just made my purchase and thought I'd play with the Launcher on my Win10 box while I wait [patiently]Ö the download seems to have installed v2.45, but the bottom says "Diamond Users! Major Upgrade is Waiting for you"... however, clicking on that box doesn't seem to update me from v2.45 to v2.64.  Also, it seems to have installed the 32bit version instead of the 64bit one.   
Thanks in advance for all help

Send a PM to RSX_Engineering here on the forum, if nobody else can help.  Iíve got a Mac, so Iím useless to you here.  Sorry.
Logged

Aeon LE v3 in Consular Green
Initiate v2 in Fire Orange
Initiate v2 in Arctic Blue
Dark Apprentice LE v5 in Adegan Silver
Azure Fallen (Diamond) in Dark Violet Amethyst
Frankensaber (Diamond) in Sentinel Yellow fading to Consular Green, with Guardian Blue  FoC ó Currently traveling with co-owner

Light Side points preferred, when warranted

DarthSyronimus
Knight Arbiter
*

Force Alignment: -40
Posts: 296


WWW
« Reply #154 on: January 29, 2020, 12:38:03 PM »

Send a PM to RSX_Engineering here on the forum, if nobody else can help.  Iíve got a Mac, so Iím useless to you here.  Sorry.

thanks, will do.
Logged

Dark Side here, Grey in RPGs
(Order#1 - Ordered 1/27/20 - Arrived 3/12/20)
* Diamond Dominicide for me (died 4/2/20, sent back 5/23/20 for repairs, back in hand and working 6/4/2020)
* Diamond Dark Apprentice LE v5 for the 10yo Padawan
* Stunt Aeon LE v3 - Blazing Red (FreeMysteryBox) for the missus
* Stunt Initiate v2 - Guardian Blue (FreeInitiate) for the 7yo Youngling
(Order #2 - Ordered 5/17/20 - Arrived 9/13/20)
* Stunt Dark Overlord - Consular Green ($75 Mystery Box)
* Yari (Pike) Extension with 16" UEHG
* Silver Vented QR Coupler

Kain_Hydrannos
Force Sensitive
*

Force Alignment: 0
Posts: 3


« Reply #155 on: March 24, 2020, 01:22:45 AM »

Hello Friends,

I am a first time UltraSabers buyer, and am attempting to use the diamond launcher software. However, I'm a Mac user and currently when I try to launch the software it tells me that the software can't be opened because it "may not be compatible with this version of OS", but when I check the update status on my computer I'm up to date on the OS software. Is there something I'm missing/doing wrong when downloading the launcher software? It also appears that when I attach the USB to my diamond controller the cable doesn't go all the way in and gets stuck. Any advice or insight on that front would also be greatly appreciated.


Logged

Jedi Elite Barson
Force Sensitive
*

Force Alignment: 0
Posts: 3


« Reply #156 on: August 02, 2020, 07:31:28 AM »

I'm a new owner/user as well and after finally getting the diamond controller out of the saber, I can't seem to get it to connect with the software.

I downloaded the latest windows version (2.45 I believe) and I use Windows 10.  do I need another download version?

As far as I know I downloaded everything correctly, even did it twice, but no reaction even though the same USB cable works fine with the charger for the batteries.

Anyone else have Windows 10, 64-bit that can provide some guidance/help?

Logged

DarthSyronimus
Knight Arbiter
*

Force Alignment: -40
Posts: 296


WWW
« Reply #157 on: August 03, 2020, 09:48:18 AM »

I'm a new owner/user as well and after finally getting the diamond controller out of the saber, I can't seem to get it to connect with the software.


Was this not helpful?
http://www.saberforum.com/index.php?topic=45691.0
Logged

Dark Side here, Grey in RPGs
(Order#1 - Ordered 1/27/20 - Arrived 3/12/20)
* Diamond Dominicide for me (died 4/2/20, sent back 5/23/20 for repairs, back in hand and working 6/4/2020)
* Diamond Dark Apprentice LE v5 for the 10yo Padawan
* Stunt Aeon LE v3 - Blazing Red (FreeMysteryBox) for the missus
* Stunt Initiate v2 - Guardian Blue (FreeInitiate) for the 7yo Youngling
(Order #2 - Ordered 5/17/20 - Arrived 9/13/20)
* Stunt Dark Overlord - Consular Green ($75 Mystery Box)
* Yari (Pike) Extension with 16" UEHG
* Silver Vented QR Coupler

Mythbras
Force Sensitive
*

Force Alignment: 0
Posts: 2



« Reply #158 on: April 02, 2021, 09:10:15 AM »

Hi
I installed the SW on my Mac and all seemed to be in order, however when I connect my sabres to the computer, nothing happens and it does not connect to the sabreÖ can you please tell me what am I doing wrong??? is there anything missing?
I downloaded the SW jus a couple of days ago
Logged

nunya
Knight Templar
*

Force Alignment: 35
Posts: 304



« Reply #159 on: April 02, 2021, 12:31:26 PM »

I'm a new owner/user as well and after finally getting the diamond controller out of the saber, I can't seem to get it to connect with the software.
I downloaded the latest windows version (2.45 I believe) and I use Windows 10.  do I need another download version?
As far as I know I downloaded everything correctly, even did it twice, but no reaction even though the same USB cable works fine with the charger for the batteries.
Anyone else have Windows 10, 64-bit that can provide some guidance/help?
It sounds like my issue after repair - here is my post:
After the Diamond Controller was replaced, I was unable to connect to the controller from the Launcher software.
Nothing had changed on my local setup except the new card and neither the launcher nor the computer presented an error message after connecting and powering on the saber.
With the saber on and connected to the computer, I checked "Device Manager" and looked under "Ports" to notice a "Diamond Controller" entry with a warning icon.  It indicated the registry entry was invalid and it seemed the driver did not want to work.
I removed the driver using Device Manager, uninstalled all parts of the launcher software (i had to restart then remove the root folder where the software was previously installed) and reinstalled once again.  I was then able to successfully connect to the saber.

As for the cable, use it between your phone/tablet and computer. If you can upload/download files then it should suffice for the saber.

may the force be with you
Logged

nunya
Knight Templar
*

Force Alignment: 35
Posts: 304



« Reply #160 on: August 23, 2021, 02:59:55 PM »

Okay, so i could not scroll to see the windows installer in the first post on this thread - finally realized what i was doing wrong Sad
https://1a32fe05fffb6725aab1-5c5b03604a40d0d2efae65b6edf685a4.ssl.cf5.rackcdn.com/UltraSabersLauncher_OfflineInstallerV245.zip
Logged

Ken at Sunrise
Knight Ensign
*

Force Alignment: 16
Posts: 151



WWW
« Reply #161 on: August 30, 2021, 08:35:55 AM »

I just saw a video (https://www.youtube.com/watch?v=xssyi7PFGRU) from Emory about the UtraPixel String Blade & NEW Obsidian Soundboards. But I only see the 2.45 software.

I'm curious if my sound board can use the new software and some of it's features. Also where is the software?

Thank you,
Logged

Always try to do what is right.

Pages: 1 ... 9 10 [11]   Go Up
Send this topic | Print
Jump to: